What’s Vulnerable › Vulnerabilities
CVE-2018-20717
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-01-15 · updated 2026-06-17
- Weakness: CWE-94
Description
In the orders section of PrestaShop before 1.7.2.5, an attack is possible after gaining access to a target store with a user role with the rights of at least a Salesman or higher privileges. The attacker can then inject arbitrary PHP objects into the process and abuse an object chain in order to gain Remote Code Execution. This occurs because protection against serialized objects looks for a 0: followed by an integer, but does not consider 0:+ followed by an integer.
Affected products
- PrestaShop: before 1.7.2.5 — fixed in 1.7.2.5
How to fix
Upgrade to a fixed version: PrestaShop 1.7.2.5. Check the vendor advisory for mitigations.
References
- https://blog.ripstech.com/2018/prestashop-remote-code-execution/
- https://build.prestashop.com/news/prestashop-1-7-2-5-maintenance-release/
- https://blog.ripstech.com/2018/prestashop-remote-code-execution/
- https://build.prestashop.com/news/prestashop-1-7-2-5-maintenance-release/
Get alerted when CVE-2018-20717 or the next vulnerability affects your stack