What’s Vulnerable › Vulnerabilities
CVE-2018-20718
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-01-15 · updated 2026-06-17
- Weakness: CWE-502
Description
In Pydio before 8.2.2, an attack is possible via PHP Object Injection because a user is allowed to use the $phpserial$a:0:{} syntax to store a preference. An attacker either needs a "public link" of a file, or access to any unprivileged user account for creation of such a link.
Affected products
- Pydio: before 8.2.2 — fixed in 8.2.2
How to fix
Upgrade to a fixed version: Pydio 8.2.2. Check the vendor advisory for mitigations.
References
- https://blog.ripstech.com/2018/pydio-unauthenticated-remote-code-execution/
- https://blog.ripstech.com/2018/pydio-unauthenticated-remote-code-execution/
Get alerted when CVE-2018-20718 or the next vulnerability affects your stack