What’s Vulnerable › Vulnerabilities
CVE-2018-20724
- Severity: medium (CVSS 4.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-01-16 · updated 2026-06-17
- Weakness: CWE-79
Description
A cross-site scripting (XSS) vulnerability exists in pollers.php in Cacti before 1.2.0 due to lack of escaping of unintended characters in the Website Hostname for Data Collectors.
Affected products
- cacti: before 1.2.0 — fixed in 1.2.0
How to fix
Upgrade to a fixed version: cacti 1.2.0. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00001.html
- http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00005.html
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00042.html
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00048.html
- https://github.com/Cacti/cacti/blob/develop/CHANGELOG
- https://github.com/Cacti/cacti/commit/1f42478506d83d188f68ce5ff41728a7bd159f53
- https://github.com/Cacti/cacti/issues/2212
- http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00001.html
- http://lists.opensuse.org/opensuse-security-announce/2020-03/msg00005.html
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00042.html
- http://lists.opensuse.org/opensuse-security-announce/2020-04/msg00048.html
- https://github.com/Cacti/cacti/blob/develop/CHANGELOG
Get alerted when CVE-2018-20724 or the next vulnerability affects your stack