What’s Vulnerable › Vulnerabilities
CVE-2018-20732
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 4.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-01-17 · updated 2026-06-17
- Weakness: CWE-502
Description
SAS Web Infrastructure Platform before 9.4M6 allows remote attackers to execute arbitrary code via a Java deserialization variant.
Affected products
- Sas Web Infrastructure Platform: before 9.4; 9.4, 9.4-maintenance_release_1, 9.4-maintenance_release_2, 9.4-maintenance_release_3, 9.4-maintenance_release_4, 9.4-maintenance_release_5 — fixed in 9.4
How to fix
Upgrade to a fixed version: Sas Web Infrastructure Platform 9.4. Check the vendor advisory for mitigations.
References
- http://www.securityfocus.com/bid/106648
- https://support.sas.com/kb/63/391.html
- http://www.securityfocus.com/bid/106648
- https://support.sas.com/kb/63/391.html
Get alerted when CVE-2018-20732 or the next vulnerability affects your stack