What’s Vulnerable › Vulnerabilities
CVE-2018-20783
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 5.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-02-21 · updated 2026-06-17
- Weakness: CWE-125
Description
In PHP before 5.6.39, 7.x before 7.0.33, 7.1.x before 7.1.25, and 7.2.x before 7.2.13, a buffer over-read in PHAR reading functions may allow an attacker to read allocated or unallocated memory past the actual data when trying to parse a .phar file. This is related to phar_parse_pharfile in ext/phar/phar.c.
Affected products
- openSUSE Leap: 42.3
- PHP: before 5.6.39; from 7.0.0 before 7.0.33; from 7.1.0 before 7.1.25; from 7.2.0 before 7.2.13 — fixed in 5.6.39, 7.0.33, 7.1.25, 7.2.13
How to fix
Upgrade to a fixed version: PHP 5.6.39, 7.0.33, 7.1.25, 7.2.13. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00083.html
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00104.html
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00041.html
- http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00044.html
- http://php.net/ChangeLog-5.php
- http://php.net/ChangeLog-7.php
- https://access.redhat.com/errata/RHSA-2019:2519
- https://access.redhat.com/errata/RHSA-2019:3299
- https://bugs.php.net/bug.php?id=77143
- https://usn.ubuntu.com/3566-2/
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00083.html
- http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00104.html
Get alerted when CVE-2018-20783 or the next vulnerability affects your stack