What’s Vulnerable › Vulnerabilities
CVE-2018-20801
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.2% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-03-14 · updated 2026-06-17
- Weakness: CWE-185
Description
In js/parts/SvgRenderer.js in Highcharts JS before 6.1.0, the use of backtracking regular expressions permitted an attacker to conduct a denial of service attack against the SVGRenderer component, aka ReDoS.
Affected products
- highcharts: before 6.1.0 — fixed in 6.1.0
How to fix
Upgrade to a fixed version: highcharts 6.1.0. Check the vendor advisory for mitigations.
References
- https://github.com/highcharts/highcharts/commit/7c547e1e0f5e4379f94396efd559a566668c0dfa
- https://security.netapp.com/advisory/ntap-20190715-0001/
- https://snyk.io/vuln/npm:highcharts:20180225
- https://github.com/highcharts/highcharts/commit/7c547e1e0f5e4379f94396efd559a566668c0dfa
- https://security.netapp.com/advisory/ntap-20190715-0001/
- https://snyk.io/vuln/npm:highcharts:20180225
Get alerted when CVE-2018-20801 or the next vulnerability affects your stack