What’s Vulnerable › Vulnerabilities
CVE-2018-20802: Post-auth queries on compound index may crash mongod
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-11-23 · updated 2026-06-17
- Weakness: CWE-394
Description
A user authorized to perform database queries may trigger denial of service by issuing specially crafted queries with compound indexes affecting QueryPlanner. This issue affects MongoDB Server v3.6 versions prior to 3.6.9 and MongoDB Server v4.0 versions prior to 4.0.3.
Affected products
- MongoDB: from 3.6.0 before 3.6.9; from 4.0.0 before 4.0.3 — fixed in 3.6.9, 4.0.3
How to fix
Upgrade to a fixed version: MongoDB 3.6.9, 4.0.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2018-20802 or the next vulnerability affects your stack