What’s Vulnerable › Vulnerabilities
CVE-2018-20838
- Severity: medium (CVSS 5.4 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-05-13 · updated 2026-06-17
- Weakness: CWE-79
Description
ampforwp_save_steps_data in the AMP for WP plugin before 0.9.97.21 for WordPress allows stored XSS.
Affected products
- Ahmed Kaludi, Mohammed Kaludi AMP for WP – Accelerated Mobile Pages: before 0.9.97.21 — fixed in 0.9.97.21
How to fix
Upgrade to a fixed version: Ahmed Kaludi, Mohammed Kaludi AMP for WP – Accelerated Mobile Pages 0.9.97.21. Check the vendor advisory for mitigations.
References
- https://ampforwp.com/critical-security-issues-has-been-fixed-in-0-9-97-20-version/
- https://plugins.trac.wordpress.org/browser/accelerated-mobile-pages/trunk/changelog.txt
- https://wordpress.org/plugins/accelerated-mobile-pages/#developers
- https://www.wordfence.com/blog/2018/11/xss-injection-campaign-exploits-wordpress-amp-plugin/
- https://ampforwp.com/critical-security-issues-has-been-fixed-in-0-9-97-20-version/
- https://plugins.trac.wordpress.org/browser/accelerated-mobile-pages/trunk/changelog.txt
- https://wordpress.org/plugins/accelerated-mobile-pages/#developers
- https://www.wordfence.com/blog/2018/11/xss-injection-campaign-exploits-wordpress-amp-plugin/
Get alerted when CVE-2018-20838 or the next vulnerability affects your stack