What’s Vulnerable › Vulnerabilities
CVE-2018-20843
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 7.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-06-24 · updated 2026-10-14
- Weakness: CWE-611
Description
In libexpat in Expat before 2.2.7, XML input including XML names that contain a large number of colons could make the XML parser consume a high amount of RAM and CPU resources while processing (enough to be usable for denial-of-service attacks).
Affected products
- Canonical Ubuntu Linux: 12.04, 14.04, 16.04, 18.04, 18.10, 19.04
- Debian Linux: 8.0, 9.0
- Fedoraproject Fedora: 29, 30
- libexpat project libexpat: before 2.2.7 — fixed in 2.2.7
- openSUSE Leap: 15.0, 15.1
- Oracle Corporation Hospitality RES 3700: from 5.7 through 5.7.6
- Oracle Corporation Oracle HTTP Server: 12.1.3.0, 12.2.1.4.0
- Oracle Corporation Outside In Technology: 8.5.4, 8.5.5
- Tenable Nessus: before 8.15.0 — fixed in 8.15.0
How to fix
Upgrade to a fixed version: libexpat project libexpat 2.2.7; Tenable Nessus 8.15.0. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-07/msg00039.html
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=5226
- https://github.com/libexpat/libexpat/blob/R_2_2_7/expat/Changes
- https://github.com/libexpat/libexpat/issues/186
- https://github.com/libexpat/libexpat/pull/262
- https://github.com/libexpat/libexpat/pull/262/commits/11f8838bf99ea0a6f0b76f9760c43704d00c4ff6
- https://lists.debian.org/debian-lts-announce/2019/06/msg00028.html
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/CEJJSQSG3KSUQY4FPVHZ7ZTT7FORMFVD/
- https://lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/IDAUGEB3TUP6NEKJDBUBZX7N5OAUOOOK/
- https://seclists.org/bugtraq/2019/Jun/39
- https://security.gentoo.org/glsa/201911-08
- https://security.netapp.com/advisory/ntap-20190703-0001/
Get alerted when CVE-2018-20843 or the next vulnerability affects your stack