What’s Vulnerable › Vulnerabilities
CVE-2018-20857
- Severity: high (CVSS 7.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-26 · updated 2026-06-17
- Weakness: CWE-20
Description
Zendesk Samlr before 2.6.2 allows an XML nodes comment attack such as a name_id node with user@example.com followed by <!---->. and then the attacker's domain name.
Affected products
- Zendesk Samlr: before 2.6.2 — fixed in 2.6.2
How to fix
Upgrade to a fixed version: Zendesk Samlr 2.6.2. Check the vendor advisory for mitigations.
References
- https://github.com/zendesk/samlr/compare/v2.6.1...v2.6.2
- https://github.com/zendesk/samlr/compare/v2.6.1...v2.6.2
Get alerted when CVE-2018-20857 or the next vulnerability affects your stack