What’s Vulnerable › Vulnerabilities
CVE-2018-20860
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-30 · updated 2026-06-17
- Weakness: CWE-20
Description
libopenmpt before 0.3.13 allows a crash with malformed MED files.
Affected products
- Openmpt Libopenmpt: before 0.3.13 — fixed in 0.3.13
- openSUSE Leap: 15.0, 15.1
How to fix
Upgrade to a fixed version: Openmpt Libopenmpt 0.3.13. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00084.html
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00085.html
- https://lib.openmpt.org/libopenmpt/2018/10/21/security-updates-0.3.13-0.2.10933-beta36-0.2.7561-beta20.5-p11-0.2.7386-beta20.3-p14/
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00084.html
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00085.html
- https://lib.openmpt.org/libopenmpt/2018/10/21/security-updates-0.3.13-0.2.10933-beta36-0.2.7561-beta20.5-p11-0.2.7386-beta20.3-p14/
Get alerted when CVE-2018-20860 or the next vulnerability affects your stack