What’s Vulnerable › Vulnerabilities
CVE-2018-20861
- Severity: medium (CVSS 6.5 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-07-30 · updated 2026-06-17
- Weakness: CWE-20
Description
libopenmpt before 0.3.11 allows a crash with certain malformed custom tunings in MPTM files.
Affected products
- Openmpt Libopenmpt: before 0.3.11 — fixed in 0.3.11
How to fix
Upgrade to a fixed version: Openmpt Libopenmpt 0.3.11. Check the vendor advisory for mitigations.
References
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00084.html
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00085.html
- https://lib.openmpt.org/libopenmpt/2018/07/28/security-updates-0.3.11-0.2.10635-beta34-0.2.7561-beta20.5-p10-0.2.7386-beta20.3-p13/
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00084.html
- http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00085.html
- https://lib.openmpt.org/libopenmpt/2018/07/28/security-updates-0.3.11-0.2.10635-beta34-0.2.7561-beta20.5-p10-0.2.7386-beta20.3-p13/
Get alerted when CVE-2018-20861 or the next vulnerability affects your stack