What’s Vulnerable › Vulnerabilities

CVE-2018-20961

Description

In the Linux kernel before 4.16.4, a double free vulnerability in the f_midi_set_alt function of drivers/usb/gadget/function/f_midi.c in the f_midi driver may allow attackers to cause a denial of service or possibly have unspecified other impact.

Affected products

How to fix

Upgrade to a fixed version: Linux kernel 4.14.36, 4.16.4, 4.4.190, 4.9.96. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2018-20961 or the next vulnerability affects your stack