What’s Vulnerable › Vulnerabilities
CVE-2018-20962
- Severity: medium (CVSS 6.1 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2019-08-08 · updated 2026-06-17
- Weakness: CWE-79
Description
The Backpack\CRUD Backpack component before 3.4.9 for Laravel allows XSS via the select field type.
Affected products
- Backpackforlaravel Backpack\Crud: before 3.4.9 — fixed in 3.4.9
How to fix
Upgrade to a fixed version: Backpackforlaravel Backpack\Crud 3.4.9. Check the vendor advisory for mitigations.
References
- https://github.com/Laravel-Backpack/CRUD/blob/master/CHANGELOG.md
- https://github.com/Laravel-Backpack/CRUD/commit/8b6bd0a2d489a4690f6b1d7ace67e2f07f5f0cc6
- https://github.com/Laravel-Backpack/CRUD/compare/3.4.8...3.4.9
- https://github.com/Laravel-Backpack/CRUD/issues/1297
- https://github.com/Laravel-Backpack/CRUD/blob/master/CHANGELOG.md
- https://github.com/Laravel-Backpack/CRUD/commit/8b6bd0a2d489a4690f6b1d7ace67e2f07f5f0cc6
- https://github.com/Laravel-Backpack/CRUD/compare/3.4.8...3.4.9
- https://github.com/Laravel-Backpack/CRUD/issues/1297
Get alerted when CVE-2018-20962 or the next vulnerability affects your stack