What’s Vulnerable › Vulnerabilities
CVE-2018-20997
- Severity: critical (CVSS 9.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-08-26 · updated 2026-06-17
- Weakness: CWE-416
Description
An issue was discovered in the openssl crate before 0.10.9 for Rust. A use-after-free occurs in CMS Signing.
Affected products
- rust-openssl: before 0.10.9 — fixed in 0.10.9
How to fix
Upgrade to a fixed version: rust-openssl 0.10.9. Check the vendor advisory for mitigations.
References
- https://rustsec.org/advisories/RUSTSEC-2018-0010.html
- https://rustsec.org/advisories/RUSTSEC-2018-0010.html
Get alerted when CVE-2018-20997 or the next vulnerability affects your stack