What’s Vulnerable › Vulnerabilities
CVE-2018-21009
- Severity: high (CVSS 8.8 v3.0)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-09-05 · updated 2026-06-17
- Weakness: CWE-190
Description
Poppler before 0.66.0 has an integer overflow in Parser::makeStream in Parser.cc.
Affected products
- poppler: before 0.76.0 — fixed in 0.76.0
How to fix
Upgrade to a fixed version: poppler 0.76.0. Check the vendor advisory for mitigations.
References
- https://gitlab.freedesktop.org/poppler/poppler/commit/0868c499a9f5f37f8df5c9fef03c37496b40fc8a
- https://lists.debian.org/debian-lts-announce/2019/09/msg00033.html
- https://lists.debian.org/debian-lts-announce/2020/07/msg00018.html
- https://gitlab.freedesktop.org/poppler/poppler/commit/0868c499a9f5f37f8df5c9fef03c37496b40fc8a
- https://lists.debian.org/debian-lts-announce/2019/09/msg00033.html
- https://lists.debian.org/debian-lts-announce/2020/07/msg00018.html
Get alerted when CVE-2018-21009 or the next vulnerability affects your stack