What’s Vulnerable › Vulnerabilities
CVE-2018-21019
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-09-23 · updated 2026-06-17
- Weakness: CWE-200
Description
Home Assistant before 0.67.0 was vulnerable to an information disclosure that allowed an unauthenticated attacker to read the application's error log via components/api.py.
Affected products
- Home-Assistant: before 0.67.0 — fixed in 0.67.0
How to fix
Upgrade to a fixed version: Home-Assistant 0.67.0. Check the vendor advisory for mitigations.
References
- https://github.com/home-assistant/home-assistant/pull/13836
- https://github.com/home-assistant/home-assistant/releases/tag/0.67.0
- https://github.com/home-assistant/home-assistant/pull/13836
- https://github.com/home-assistant/home-assistant/releases/tag/0.67.0
Get alerted when CVE-2018-21019 or the next vulnerability affects your stack