What’s Vulnerable › Vulnerabilities
CVE-2018-21030
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2019-10-31 · updated 2026-06-17
- Weakness: CWE-79
Description
Jupyter Notebook before 5.5.0 does not use a CSP header to treat served files as belonging to a separate origin. Thus, for example, an XSS payload can be placed in an SVG document.
Affected products
- jupyter notebook: before 5.5.0 — fixed in 5.5.0
How to fix
Upgrade to a fixed version: jupyter notebook 5.5.0. Check the vendor advisory for mitigations.
References
- https://github.com/jupyter/notebook/pull/3341
- https://github.com/jupyter/notebook/releases/tag/5.5.0
- https://lists.debian.org/debian-lts-announce/2020/11/msg00033.html
- https://github.com/jupyter/notebook/pull/3341
- https://github.com/jupyter/notebook/releases/tag/5.5.0
- https://lists.debian.org/debian-lts-announce/2020/11/msg00033.html
Get alerted when CVE-2018-21030 or the next vulnerability affects your stack