What’s Vulnerable › Vulnerabilities
CVE-2018-21036
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-07-21 · updated 2026-06-17
- Weakness: CWE-20
Description
Sails.js before v1.0.0-46 allows attackers to cause a denial of service with a single request because there is no error handler in sails-hook-sockets to handle an empty pathname in a WebSocket request.
Affected products
- balderdashy sails: before 1.0.0-46 — fixed in 1.0.0-46
How to fix
Upgrade to a fixed version: balderdashy sails 1.0.0-46. Check the vendor advisory for mitigations.
References
- http://www.openwall.com/lists/oss-security/2020/07/19/1
- https://github.com/balderdashy/sails-hook-sockets/commit/0533a4864b1920fd8fbb5287bc0889193c5faf44
- https://github.com/balderdashy/sails-hook-sockets/commit/ff02114eaec090ee51db48435cc32d451662606e
- https://github.com/balderdashy/sails/blob/56f8276f6501a144a03d1f0f28df4ccdb4ad82e2/CHANGELOG.md
- http://www.openwall.com/lists/oss-security/2020/07/19/1
- https://github.com/balderdashy/sails-hook-sockets/commit/0533a4864b1920fd8fbb5287bc0889193c5faf44
- https://github.com/balderdashy/sails-hook-sockets/commit/ff02114eaec090ee51db48435cc32d451662606e
- https://github.com/balderdashy/sails/blob/56f8276f6501a144a03d1f0f28df4ccdb4ad82e2/CHANGELOG.md
Get alerted when CVE-2018-21036 or the next vulnerability affects your stack