What’s Vulnerable › Vulnerabilities

CVE-2018-21093

Description

Certain NETGEAR devices are affected by a stack-based buffer overflow by an unauthenticated attacker. This affects D8500 before 1.0.3.42, EX3700 before 1.0.0.70, EX3800 before 1.0.0.70, EX6000 before 1.0.0.30, EX6100 before 1.0.2.24, EX6120 before 1.0.0.40, EX6130 before 1.0.0.22, EX6150 before 1.0.0.42, EX6200 before 1.0.3.88, EX7000 before 1.0.0.66, R6250 before 1.0.4.26, R6300-2CXNAS before 1.0.3.60, R6300v2 before 1.0.4.28, R6400 before 1.0.1.36, R6400v2 before 1.0.2.52, R6700 before 1.0.1.46, R6900 before 1.0.1.46, R7000 before 1.0.9.28, R7000P before 1.3.1.44, R6900P before 1.3.1.44, R7100LG before 1.0.0.46, R7300 before 1.0.0.68, R7900 before 1.0.2.10, R8000 before 1.0.4.18, R8000P before 1.3.0.10, R7900P before 1.3.0.10, R8500 before 1.0.2.122, R8300 before 1.0.2.122, RBW30 before 2.1.2.6, WN2500RPv2 before 1.0.0.54, and WNR3500Lv2 before 1.2.0.56.

Affected products

How to fix

Upgrade to a fixed version: NETGEAR D8500 Firmware 1.0.3.42; NETGEAR EX3700 1.0.0.70; NETGEAR Ex3800 Firmware 1.0.0.70; NETGEAR Ex6000 Firmware 1.0.0.30; Netgear EX6100 1.0.2.24; NETGEAR EX6120 1.0.0.40; NETGEAR Ex6130 Firmware 1.0.0.22; Netgear EX6150 1.0.0.42; Netgear EX6200 1.0.3.88; NETGEAR Ex7000 Firmware 1.0.0.66; NETGEAR R6250 Firmware 1.0.4.26; NETGEAR R6300-2Cxnas Firmware 1.0.3.60. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2018-21093 or the next vulnerability affects your stack