What’s Vulnerable › Vulnerabilities
CVE-2018-21112
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-22 · updated 2026-06-17
- Weakness: CWE-74
Description
Certain NETGEAR devices are affected by command injection by an authenticated user. This affects D7800 before 1.0.1.44, R7500v2 before 1.0.3.38, R7800 before 1.0.2.52, R8900 before 1.0.4.12, and R9000 before 1.0.4.12.
Affected products
- NETGEAR D7800 Firmware: before 1.0.1.44 — fixed in 1.0.1.44
- NETGEAR R7500 Firmware: before 1.0.3.38 — fixed in 1.0.3.38
- NETGEAR R7800 Firmware: before 1.0.2.52 — fixed in 1.0.2.52
- NETGEAR R8900 Firmware: before 1.0.4.12 — fixed in 1.0.4.12
- NETGEAR R9000 Firmware: before 1.0.4.12 — fixed in 1.0.4.12
How to fix
Upgrade to a fixed version: NETGEAR D7800 Firmware 1.0.1.44; NETGEAR R7500 Firmware 1.0.3.38; NETGEAR R7800 Firmware 1.0.2.52; NETGEAR R8900 Firmware 1.0.4.12; NETGEAR R9000 Firmware 1.0.4.12. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000060439/Security-Advisory-for-Post-Authentication-Command-Injection-on-Some-Routers-and-Modem-Routers-PSV-2018-0093
- https://kb.netgear.com/000060439/Security-Advisory-for-Post-Authentication-Command-Injection-on-Some-Routers-and-Modem-Routers-PSV-2018-0093
Get alerted when CVE-2018-21112 or the next vulnerability affects your stack