What’s Vulnerable › Vulnerabilities
CVE-2018-21113
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-22 · updated 2026-06-17
- Weakness: CWE-74
Description
Certain NETGEAR devices are affected by command injection by an unauthenticated attacker. This affects D6100 before 1.0.0.58, D7800 before 1.0.1.42, R6100 before 1.0.1.28, R7500 before 1.0.0.130, R7500v2 before 1.0.3.36, R7800 before 1.0.2.52, R8900 before 1.0.4.12, R9000 before 1.0.4.12, WNDR3700v4 before 1.0.2.102, WNDR4300 before 1.0.2.104, WNDR4300v2 before 1.0.0.56, and WNDR4500v3 before 1.0.0.56.
Affected products
- NETGEAR D6100 Firmware: before 1.0.0.58 — fixed in 1.0.0.58
- NETGEAR D7800 Firmware: before 1.0.1.42 — fixed in 1.0.1.42
- NETGEAR R6100 Firmware: before 1.0.1.28 — fixed in 1.0.1.28
- NETGEAR R7500 Firmware: before 1.0.0.130; before 1.0.3.36 — fixed in 1.0.0.130, 1.0.3.36
- NETGEAR R7800 Firmware: before 1.0.2.52 — fixed in 1.0.2.52
- NETGEAR R8900 Firmware: before 1.0.4.12 — fixed in 1.0.4.12
- NETGEAR R9000 Firmware: before 1.0.4.12 — fixed in 1.0.4.12
- NETGEAR Wndr3700 Firmware: before 1.0.2.102 — fixed in 1.0.2.102
- NETGEAR Wndr4300 Firmware: before 1.0.2.104; before 1.0.0.56 — fixed in 1.0.0.56, 1.0.2.104
- Netgear WNDR4500: before 1.0.0.56 — fixed in 1.0.0.56
How to fix
Upgrade to a fixed version: NETGEAR D6100 Firmware 1.0.0.58; NETGEAR D7800 Firmware 1.0.1.42; NETGEAR R6100 Firmware 1.0.1.28; NETGEAR R7500 Firmware 1.0.0.130, 1.0.3.36; NETGEAR R7800 Firmware 1.0.2.52; NETGEAR R8900 Firmware 1.0.4.12; NETGEAR R9000 Firmware 1.0.4.12; NETGEAR Wndr3700 Firmware 1.0.2.102; NETGEAR Wndr4300 Firmware 1.0.0.56, 1.0.2.104; Netgear WNDR4500 1.0.0.56. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000060438/Security-Advisory-for-Pre-Authentication-Command-Injection-on-Some-Routers-and-Modem-Routers-PSV-2018-0033
- https://kb.netgear.com/000060438/Security-Advisory-for-Pre-Authentication-Command-Injection-on-Some-Routers-and-Modem-Routers-PSV-2018-0033
Get alerted when CVE-2018-21113 or the next vulnerability affects your stack