What’s Vulnerable › Vulnerabilities

CVE-2018-21134

Description

Certain NETGEAR devices are affected by a stack-based buffer overflow by an unauthenticated attacker. This affects R6700 before 1.0.1.48, R7900 before 1.0.2.16, R6900 before 1.0.1.48, R7000P before 1.3.1.44, R6900P before 1.3.1.44, R6250 before 1.0.4.30, R6300v2 before 1.0.4.32, R6400 before 1.0.1.44, R6400v2 before 1.0.2.60, R7000 before 1.0.9.34, R7100LG before 1.0.0.48, R7300 before 1.0.0.68, R8000 before 1.0.4.18, R8000P before 1.4.1.24, R7900P before 1.4.1.24, R8500 before 1.0.2.122, R8300 before 1.0.2.122, WN2500RPv2 before 1.0.1.54, EX3700 before 1.0.0.72, EX3800 before 1.0.0.72, EX6000 before 1.0.0.32, EX6100 before 1.0.2.24, EX6120 before 1.0.0.42, EX6130 before 1.0.0.24, EX6150v1 before 1.0.0.42, EX6200 before 1.0.3.88, EX7000 before 1.0.0.66, D7000v2 before 1.0.0.51, D6220 before 1.0.0.46, D6400 before 1.0.0.82, and D8500 before 1.0.3.42.

Affected products

How to fix

Upgrade to a fixed version: NETGEAR D6220 Firmware 1.0.0.46; Netgear D6400 1.0.0.82; NETGEAR D7000 Firmware 1.0.0.51; NETGEAR D8500 Firmware 1.0.3.42; NETGEAR EX3700 1.0.0.72; NETGEAR Ex3800 Firmware 1.0.0.72; NETGEAR Ex6000 Firmware 1.0.0.32; Netgear EX6100 1.0.2.24; NETGEAR EX6120 1.0.0.42; NETGEAR Ex6130 Firmware 1.0.0.24; Netgear EX6150 1.0.0.42; Netgear EX6200 1.0.3.88. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2018-21134 or the next vulnerability affects your stack