What’s Vulnerable › Vulnerabilities
CVE-2018-21144
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-21 · updated 2026-06-17
- Weakness: CWE-787
Description
Certain NETGEAR devices are affected by a stack-based buffer overflow by an authenticated user. This affects DM200 before 1.0.0.52, R7500 before 1.0.0.122, R7800 before 1.0.2.42, R8900 before 1.0.3.10, R9000 before 1.0.3.16, WNDR3700v4 before 1.0.2.96, WNDR4300 before 1.0.2.98, WNDR4300v2 before 1.0.0.54, WNDR4500v3 before 1.0.0.54, and WNR2000v5 before 1.0.0.64.
Affected products
- NETGEAR Dm200 Firmware: before 1.0.0.52 — fixed in 1.0.0.52
- NETGEAR R7500 Firmware: before 1.0.0.122 — fixed in 1.0.0.122
- NETGEAR R7800 Firmware: before 1.0.2.42 — fixed in 1.0.2.42
- NETGEAR R8900 Firmware: before 1.0.3.10 — fixed in 1.0.3.10
- NETGEAR R9000 Firmware: before 1.0.3.16 — fixed in 1.0.3.16
- NETGEAR Wndr3700 Firmware: before 1.0.2.96 — fixed in 1.0.2.96
- NETGEAR Wndr4300 Firmware: before 1.0.2.98; before 1.0.0.54 — fixed in 1.0.0.54, 1.0.2.98
- Netgear WNDR4500: before 1.0.0.54 — fixed in 1.0.0.54
- NETGEAR Wnr2000 Firmware: before 1.0.0.64 — fixed in 1.0.0.64
How to fix
Upgrade to a fixed version: NETGEAR Dm200 Firmware 1.0.0.52; NETGEAR R7500 Firmware 1.0.0.122; NETGEAR R7800 Firmware 1.0.2.42; NETGEAR R8900 Firmware 1.0.3.10; NETGEAR R9000 Firmware 1.0.3.16; NETGEAR Wndr3700 Firmware 1.0.2.96; NETGEAR Wndr4300 Firmware 1.0.0.54, 1.0.2.98; Netgear WNDR4500 1.0.0.54; NETGEAR Wnr2000 Firmware 1.0.0.64. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000059489/Security-Advisory-for-Post-Authentication-Stack-Overflow-on-Some-Routers-PSV-2017-3166
- https://kb.netgear.com/000059489/Security-Advisory-for-Post-Authentication-Stack-Overflow-on-Some-Routers-PSV-2017-3166
Get alerted when CVE-2018-21144 or the next vulnerability affects your stack