What’s Vulnerable › Vulnerabilities
CVE-2018-21170
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-27 · updated 2026-06-17
- Weakness: CWE-787
Description
Certain NETGEAR devices are affected by a stack-based buffer overflow by an unauthenticated attacker. This affects EX2700 before 1.0.1.28, R7800 before 1.0.2.40, WN2000RPTv3 before 1.0.1.20, WN3000RPv3 before 1.0.2.50, and WN3100RPv2 before 1.0.0.56.
Affected products
- NETGEAR Ex2700 Firmware: before 1.0.1.28 — fixed in 1.0.1.28
- NETGEAR R7800 Firmware: before 1.0.2.40 — fixed in 1.0.2.40
- NETGEAR Wn2000Rpt Firmware: before 1.0.1.20 — fixed in 1.0.1.20
- NETGEAR Wn3000Rp Firmware: before 1.0.2.50 — fixed in 1.0.2.50
- NETGEAR Wn3100Rp Firmware: before 1.0.0.56 — fixed in 1.0.0.56
How to fix
Upgrade to a fixed version: NETGEAR Ex2700 Firmware 1.0.1.28; NETGEAR R7800 Firmware 1.0.2.40; NETGEAR Wn2000Rpt Firmware 1.0.1.20; NETGEAR Wn3000Rp Firmware 1.0.2.50; NETGEAR Wn3100Rp Firmware 1.0.0.56. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000055188/Security-Advisory-for-Pre-Authentication-Stack-Overflow-on-Some-Routers-and-Extenders-PSV-2017-2638
- https://kb.netgear.com/000055188/Security-Advisory-for-Pre-Authentication-Stack-Overflow-on-Some-Routers-and-Extenders-PSV-2017-2638
Get alerted when CVE-2018-21170 or the next vulnerability affects your stack