What’s Vulnerable › Vulnerabilities
CVE-2018-21181
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-28 · updated 2026-06-17
- Weakness: CWE-787
Description
Certain NETGEAR devices are affected by a stack-based buffer overflow by an authenticated user. This affects D7800 before 1.0.1.28, EX2700 before 1.0.1.32, EX6200v2 before 1.0.1.56, R7500v2 before 1.0.3.24, R7800 before 1.0.2.40, R9000 before 1.0.3.6, WN2000RPTv3 before 1.0.1.20, WN3000RPv3 before 1.0.2.52, WN3100RPv2 before 1.0.0.42, WNDR3700v4 before 1.0.2.92, WNDR4300 before 1.0.2.94, WNDR4300v2 before 1.0.0.50, WNDR4500v3 before 1.0.0.50, and WNR2000v5 before 1.0.0.62.
Affected products
- NETGEAR D7800 Firmware: before 1.0.1.28 — fixed in 1.0.1.28
- NETGEAR Ex2700 Firmware: before 1.0.1.32 — fixed in 1.0.1.32
- Netgear EX6200: before 1.0.1.56 — fixed in 1.0.1.56
- NETGEAR R7500 Firmware: before 1.0.3.24 — fixed in 1.0.3.24
- NETGEAR R7800 Firmware: before 1.0.2.40 — fixed in 1.0.2.40
- NETGEAR R9000 Firmware: before 1.0.3.6 — fixed in 1.0.3.6
- NETGEAR Wn2000Rpt Firmware: before 1.0.1.20 — fixed in 1.0.1.20
- NETGEAR Wn3000Rp Firmware: before 1.0.2.52 — fixed in 1.0.2.52
- NETGEAR Wn3100Rp Firmware: before 1.0.0.42 — fixed in 1.0.0.42
- NETGEAR Wndr3700 Firmware: before 1.0.2.92 — fixed in 1.0.2.92
- NETGEAR Wndr4300 Firmware: before 1.0.2.94; before 1.0.0.50 — fixed in 1.0.0.50, 1.0.2.94
- Netgear WNDR4500: before 1.0.0.50 — fixed in 1.0.0.50
- NETGEAR Wnr2000 Firmware: before 1.0.0.62 — fixed in 1.0.0.62
How to fix
Upgrade to a fixed version: NETGEAR D7800 Firmware 1.0.1.28; NETGEAR Ex2700 Firmware 1.0.1.32; Netgear EX6200 1.0.1.56; NETGEAR R7500 Firmware 1.0.3.24; NETGEAR R7800 Firmware 1.0.2.40; NETGEAR R9000 Firmware 1.0.3.6; NETGEAR Wn2000Rpt Firmware 1.0.1.20; NETGEAR Wn3000Rp Firmware 1.0.2.52; NETGEAR Wn3100Rp Firmware 1.0.0.42; NETGEAR Wndr3700 Firmware 1.0.2.92; NETGEAR Wndr4300 Firmware 1.0.0.50, 1.0.2.94; Netgear WNDR4500 1.0.0.50. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000055177/Security-Advisory-for-Post-Authentication-Stack-Overflow-on-Some-Routers-Gateways-and-Extenders-PSV-2017-2618
- https://kb.netgear.com/000055177/Security-Advisory-for-Post-Authentication-Stack-Overflow-on-Some-Routers-Gateways-and-Extenders-PSV-2017-2618
Get alerted when CVE-2018-21181 or the next vulnerability affects your stack