What’s Vulnerable › Vulnerabilities
CVE-2018-21183
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-28 · updated 2026-06-17
- Weakness: CWE-787
Description
Certain NETGEAR devices are affected by a stack-based buffer overflow by an authenticated user. This affects R7800 before 1.0.2.40, R9000 before 1.0.2.52, WNDR3700v4 before 1.0.2.92, and WNDR4300 before 1.0.2.94.
Affected products
- NETGEAR R7800 Firmware: before 1.0.2.40 — fixed in 1.0.2.40
- NETGEAR R9000 Firmware: before 1.0.2.52 — fixed in 1.0.2.52
- NETGEAR Wndr3700 Firmware: before 1.0.2.92 — fixed in 1.0.2.92
- NETGEAR Wndr4300 Firmware: before 1.0.2.94 — fixed in 1.0.2.94
How to fix
Upgrade to a fixed version: NETGEAR R7800 Firmware 1.0.2.40; NETGEAR R9000 Firmware 1.0.2.52; NETGEAR Wndr3700 Firmware 1.0.2.92; NETGEAR Wndr4300 Firmware 1.0.2.94. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000055175/Security-Advisory-for-Post-Authentication-Stack-Overflow-on-Some-Routers-PSV-2017-2616
- https://kb.netgear.com/000055175/Security-Advisory-for-Post-Authentication-Stack-Overflow-on-Some-Routers-PSV-2017-2616
Get alerted when CVE-2018-21183 or the next vulnerability affects your stack