What’s Vulnerable › Vulnerabilities

CVE-2018-21184

Description

Certain NETGEAR devices are affected by a stack-based buffer overflow by an authenticated user. This affects D6100 before 1.0.0.57, D7800 before 1.0.1.28, R7500v2 before 1.0.3.24, R7800 before 1.0.2.40, and R9000 before 1.0.3.6.

Affected products

How to fix

Upgrade to a fixed version: NETGEAR D6100 Firmware 1.0.0.57; NETGEAR D7800 Firmware 1.0.1.28; NETGEAR R7500 Firmware 1.0.3.24; NETGEAR R7800 Firmware 1.0.2.40; NETGEAR R9000 Firmware 1.0.3.6. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2018-21184 or the next vulnerability affects your stack