What’s Vulnerable › Vulnerabilities
CVE-2018-21189
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-28 · updated 2026-06-17
- Weakness: CWE-787
Description
Certain NETGEAR devices are affected by a stack-based buffer overflow by an authenticated user. This affects D6100 before 1.0.0.57, R6100 before 1.0.1.20, R7800 before 1.0.2.40, R9000 before 1.0.2.52, WNDR3700v4 before 1.0.2.92, WNDR4300 before 1.0.2.94, WNDR4300v2 before 1.0.0.50, WNDR4500v3 before 1.0.0.50, and WNR2000v5 before 1.0.0.62.
Affected products
- NETGEAR D6100 Firmware: before 1.0.0.57 — fixed in 1.0.0.57
- NETGEAR R6100 Firmware: before 1.0.1.20 — fixed in 1.0.1.20
- NETGEAR R7800 Firmware: before 1.0.2.40 — fixed in 1.0.2.40
- NETGEAR R9000 Firmware: before 1.0.2.52 — fixed in 1.0.2.52
- NETGEAR Wndr3700 Firmware: before 1.0.2.92 — fixed in 1.0.2.92
- NETGEAR Wndr4300 Firmware: before 1.0.2.94; before 1.0.0.50 — fixed in 1.0.0.50, 1.0.2.94
- Netgear WNDR4500: before 1.0.0.50 — fixed in 1.0.0.50
- NETGEAR Wnr2000 Firmware: before 1.0.0.62 — fixed in 1.0.0.62
How to fix
Upgrade to a fixed version: NETGEAR D6100 Firmware 1.0.0.57; NETGEAR R6100 Firmware 1.0.1.20; NETGEAR R7800 Firmware 1.0.2.40; NETGEAR R9000 Firmware 1.0.2.52; NETGEAR Wndr3700 Firmware 1.0.2.92; NETGEAR Wndr4300 Firmware 1.0.0.50, 1.0.2.94; Netgear WNDR4500 1.0.0.50; NETGEAR Wnr2000 Firmware 1.0.0.62. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000055168/Security-Advisory-for-Post-Authentication-Stack-Overflow-on-Some-Routers-and-Gateways-PSV-2017-2606
- https://kb.netgear.com/000055168/Security-Advisory-for-Post-Authentication-Stack-Overflow-on-Some-Routers-and-Gateways-PSV-2017-2606
Get alerted when CVE-2018-21189 or the next vulnerability affects your stack