What’s Vulnerable › Vulnerabilities

CVE-2018-21199

Description

Certain NETGEAR devices are affected by a stack-based buffer overflow by an authenticated user. This affects D7800 before 1.0.1.30, R6100 before 1.0.1.22, R7500 before 1.0.0.122, R7500v2 before 1.0.3.24, R7800 before 1.0.2.40, R9000 before 1.0.2.52, and WNDR4300 before 1.0.2.98.

Affected products

How to fix

Upgrade to a fixed version: NETGEAR D7800 Firmware 1.0.1.30; NETGEAR R6100 Firmware 1.0.1.22; NETGEAR R7500 Firmware 1.0.0.122, 1.0.3.24; NETGEAR R7800 Firmware 1.0.2.40; NETGEAR R9000 Firmware 1.0.2.52; NETGEAR Wndr4300 Firmware 1.0.2.98. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2018-21199 or the next vulnerability affects your stack