What’s Vulnerable › Vulnerabilities
CVE-2018-21200
- Severity: medium (CVSS 6.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-28 · updated 2026-06-17
- Weakness: CWE-787
Description
Certain NETGEAR devices are affected by a stack-based buffer overflow by an authenticated user. This affects R7800 before 1.0.2.40 and R9000 before 1.0.3.6.
Affected products
- NETGEAR R7800 Firmware: before 1.0.2.40 — fixed in 1.0.2.40
- NETGEAR R9000 Firmware: before 1.0.3.6 — fixed in 1.0.3.6
How to fix
Upgrade to a fixed version: NETGEAR R7800 Firmware 1.0.2.40; NETGEAR R9000 Firmware 1.0.3.6. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000055149/Security-Advisory-for-Post-Authentication-Stack-Overflow-on-Some-Routers-PSV-2017-2592
- https://kb.netgear.com/000055149/Security-Advisory-for-Post-Authentication-Stack-Overflow-on-Some-Routers-PSV-2017-2592
Get alerted when CVE-2018-21200 or the next vulnerability affects your stack