What’s Vulnerable › Vulnerabilities
CVE-2018-21203
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-28 · updated 2026-06-17
- Weakness: CWE-787
Description
Certain NETGEAR devices are affected by a stack-based buffer overflow by an unauthenticated attacker. This affects R6100 before 1.0.1.20, R9000 before 1.0.2.52, WNDR3700v4 before 1.0.2.96, WNDR4300 before 1.0.2.98, WNDR4300v2 before 1.0.0.50, and WNDR4500v3 before 1.0.0.50.
Affected products
- NETGEAR R6100 Firmware: before 1.0.1.20 — fixed in 1.0.1.20
- NETGEAR R9000 Firmware: before 1.0.2.52 — fixed in 1.0.2.52
- NETGEAR Wndr3700 Firmware: before 1.0.2.96 — fixed in 1.0.2.96
- NETGEAR Wndr4300 Firmware: before 1.0.2.98; before 1.0.0.50 — fixed in 1.0.0.50, 1.0.2.98
- Netgear WNDR4500: before 1.0.0.50 — fixed in 1.0.0.50
How to fix
Upgrade to a fixed version: NETGEAR R6100 Firmware 1.0.1.20; NETGEAR R9000 Firmware 1.0.2.52; NETGEAR Wndr3700 Firmware 1.0.2.96; NETGEAR Wndr4300 Firmware 1.0.0.50, 1.0.2.98; Netgear WNDR4500 1.0.0.50. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000055146/Security-Advisory-for-Pre-Authentication-Stack-Overflow-on-Some-Routers-PSV-2017-2589
- https://kb.netgear.com/000055146/Security-Advisory-for-Pre-Authentication-Stack-Overflow-on-Some-Routers-PSV-2017-2589
Get alerted when CVE-2018-21203 or the next vulnerability affects your stack