What’s Vulnerable › Vulnerabilities

CVE-2018-21206

Description

Certain NETGEAR devices are affected by a stack-based buffer overflow by an unauthenticated attacker. This affects D7800 before 1.0.1.30, EX2700 before 1.0.1.28, R6100 before 1.0.1.20, R7500 before 1.0.0.118, R7500v2 before 1.0.3.24, R7800 before 1.0.2.40, R9000 before 1.0.2.52, WN2000RPTv3 before 1.0.1.20, WN3000RPv3 before 1.0.2.50, WN3100RPv2 before 1.0.0.56, WNDR3700v4 before 1.0.2.96, WNDR4300 before 1.0.2.98, WNDR4300v2 before 1.0.0.50, and WNDR4500v3 before 1.0.0.50.

Affected products

How to fix

Upgrade to a fixed version: NETGEAR D7800 Firmware 1.0.1.30; NETGEAR Ex2700 Firmware 1.0.1.28; NETGEAR R6100 Firmware 1.0.1.20; NETGEAR R7500 Firmware 1.0.0.118, 1.0.3.24; NETGEAR R7800 Firmware 1.0.2.40; NETGEAR R900 Firmware 1.0.2.52; NETGEAR Wn2000Rpt Firmware 1.0.1.20; NETGEAR Wn3000Rp Firmware 1.0.2.50; NETGEAR Wn3100Rp Firmware 1.0.0.56; NETGEAR Wndr3700 Firmware 1.0.2.96; NETGEAR Wndr4300 Firmware 1.0.0.50, 1.0.2.98; Netgear WNDR4500 1.0.0.50. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2018-21206 or the next vulnerability affects your stack