What’s Vulnerable › Vulnerabilities
CVE-2018-21216
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-28 · updated 2026-06-17
- Weakness: CWE-120
Description
Certain NETGEAR devices are affected by a buffer overflow by an unauthenticated attacker. This affects D3600 before 1.0.0.67, D6000 before 1.0.0.67, D6100 before 1.0.0.56, and R6100 before 1.0.1.20.
Affected products
- NETGEAR D3600 Firmware: before 1.0.0.67 — fixed in 1.0.0.67
- NETGEAR D6000 Firmware: before 1.0.0.67 — fixed in 1.0.0.67
- NETGEAR D6100 Firmware: before 1.0.0.56 — fixed in 1.0.0.56
- NETGEAR R6100 Firmware: before 1.0.1.20 — fixed in 1.0.1.20
How to fix
Upgrade to a fixed version: NETGEAR D3600 Firmware 1.0.0.67; NETGEAR D6000 Firmware 1.0.0.67; NETGEAR D6100 Firmware 1.0.0.56; NETGEAR R6100 Firmware 1.0.1.20. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000055121/Security-Advisory-for-Pre-Authentication-Buffer-Overflow-on-Some-Routers-and-Gateways-PSV-2017-2485
- https://kb.netgear.com/000055121/Security-Advisory-for-Pre-Authentication-Buffer-Overflow-on-Some-Routers-and-Gateways-PSV-2017-2485
Get alerted when CVE-2018-21216 or the next vulnerability affects your stack