What’s Vulnerable › Vulnerabilities
CVE-2018-21221
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-04-28 · updated 2026-06-17
- Weakness: CWE-120
Description
Certain NETGEAR devices are affected by a buffer overflow by an unauthenticated attacker. This affects D3600 before 1.0.0.67, D6000 before 1.0.0.67, and R9000 before 1.0.2.52.
Affected products
- NETGEAR D3600 Firmware: before 1.0.0.67 — fixed in 1.0.0.67
- NETGEAR D6000 Firmware: before 1.0.0.67 — fixed in 1.0.0.67
- NETGEAR R9000 Firmware: before 1.0.2.52 — fixed in 1.0.2.52
How to fix
Upgrade to a fixed version: NETGEAR D3600 Firmware 1.0.0.67; NETGEAR D6000 Firmware 1.0.0.67; NETGEAR R9000 Firmware 1.0.2.52. Check the vendor advisory for mitigations.
References
- https://kb.netgear.com/000055116/Security-Advisory-for-Pre-Authentication-Buffer-Overflow-on-Some-Routers-and-Gateways-PSV-2017-2459
- https://kb.netgear.com/000055116/Security-Advisory-for-Pre-Authentication-Buffer-Overflow-on-Some-Routers-and-Gateways-PSV-2017-2459
Get alerted when CVE-2018-21221 or the next vulnerability affects your stack