What’s Vulnerable › Vulnerabilities
CVE-2018-21240
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-06-04 · updated 2026-06-17
- Weakness: CWE-400
Description
An issue was discovered in Foxit Reader and PhantomPDF before 9.2. It allows memory consumption via an ArrayBuffer(0xfffffffe) call.
Affected products
- Foxit PhantomPDF: before 9.2 — fixed in 9.2
- Foxit Reader: before 9.2 — fixed in 9.2
How to fix
Upgrade to a fixed version: Foxit PhantomPDF 9.2; Foxit Reader 9.2. Check the vendor advisory for mitigations.
References
- https://www.foxitsoftware.com/support/security-bulletins.php
- https://www.foxitsoftware.com/support/security-bulletins.php
Get alerted when CVE-2018-21240 or the next vulnerability affects your stack