What’s Vulnerable › Vulnerabilities
CVE-2018-21246
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2020-06-15 · updated 2026-06-17
- Weakness: CWE-287
Description
Caddy before 0.10.13 mishandles TLS client authentication, as demonstrated by an authentication bypass caused by the lack of the StrictHostMatching mode.
Affected products
- caddyserver caddy: before 0.10.3 — fixed in 0.10.3
How to fix
Upgrade to a fixed version: caddyserver caddy 0.10.3. Check the vendor advisory for mitigations.
References
- https://bugs.gentoo.org/715214
- https://github.com/caddyserver/caddy/releases/tag/v0.10.13
- https://bugs.gentoo.org/715214
- https://github.com/caddyserver/caddy/releases/tag/v0.10.13
Get alerted when CVE-2018-21246 or the next vulnerability affects your stack