What’s Vulnerable › Vulnerabilities
CVE-2018-21270
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 3.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-12-03 · updated 2026-06-17
- Weakness: CWE-125
Description
Versions less than 0.0.6 of the Node.js stringstream module are vulnerable to an out-of-bounds read because of allocation of uninitialized buffers when a number is passed in the input stream (when using Node.js 4.x).
Affected products
- Node.js: before 0.0.6 — fixed in 0.0.6
How to fix
Upgrade to a fixed version: Node.js 0.0.6. Check the vendor advisory for mitigations.
References
- https://github.com/mhart/StringStream/issues/7
- https://hackerone.com/reports/321670
- https://www.npmjs.com/advisories/664
- https://github.com/mhart/StringStream/issues/7
- https://hackerone.com/reports/321670
- https://www.npmjs.com/advisories/664
Get alerted when CVE-2018-21270 or the next vulnerability affects your stack