What’s Vulnerable › Vulnerabilities
CVE-2018-25001
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2020-12-31 · updated 2026-06-17
- Weakness: CWE-416
Description
An issue was discovered in the libpulse-binding crate before 2.5.0 for Rust. proplist::Iterator can cause a use-after-free.
Affected products
- Libpulse-Binding Project Libpulse-Binding: from 1.0.5 before 2.5.0 — fixed in 2.5.0
How to fix
Upgrade to a fixed version: Libpulse-Binding Project Libpulse-Binding 2.5.0. Check the vendor advisory for mitigations.
References
- https://rustsec.org/advisories/RUSTSEC-2018-0020.html
- https://rustsec.org/advisories/RUSTSEC-2018-0020.html
Get alerted when CVE-2018-25001 or the next vulnerability affects your stack