What’s Vulnerable › Vulnerabilities
CVE-2018-25004: Invariant failure when explaining a find with a UUID
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-03-01 · updated 2026-06-17
- Weakness: CWE-20
Description
A user authorized to performing a specific type of query may trigger a denial of service by issuing a generic explain command on a find query. This issue affects MongoDB Server v4.0 versions prior to 4.0.6 and MongoDB Server v3.6 versions prior to 3.6.11.
Affected products
- MongoDB: from 3.6.0 before 3.6.11; from 4.0.0 before 4.0.6 — fixed in 3.6.11, 4.0.6
How to fix
Upgrade to a fixed version: MongoDB 3.6.11, 4.0.6. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2018-25004 or the next vulnerability affects your stack