What’s Vulnerable › Vulnerabilities
CVE-2018-25010
- Severity: critical (CVSS 9.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-21 · updated 2026-06-17
- Weakness: CWE-125
Description
A heap-based buffer overflow was found in libwebp in versions before 1.0.1 in ApplyFilter().
Affected products
- Red Hat Enterprise Linux: 8.0
- Chromium libwebp: before 1.0.1 — fixed in 1.0.1
How to fix
Upgrade to a fixed version: Chromium libwebp 1.0.1. Check the vendor advisory for mitigations.
References
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=9105
- https://bugzilla.redhat.com/show_bug.cgi?id=1956918
- https://chromium.googlesource.com/webm/libwebp/+/1344a2e947c749d231141a295327e5b99b444d63
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=9105
- https://bugzilla.redhat.com/show_bug.cgi?id=1956918
- https://chromium.googlesource.com/webm/libwebp/+/1344a2e947c749d231141a295327e5b99b444d63
Get alerted when CVE-2018-25010 or the next vulnerability affects your stack