What’s Vulnerable › Vulnerabilities
CVE-2018-25011
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-21 · updated 2026-06-17
- Weakness: CWE-787
Description
A heap-based buffer overflow was found in libwebp in versions before 1.0.1 in PutLE16().
Affected products
- Red Hat Enterprise Linux: 7.0, 8.0
- Chromium libwebp: before 1.0.1 — fixed in 1.0.1
How to fix
Upgrade to a fixed version: Chromium libwebp 1.0.1. Check the vendor advisory for mitigations.
References
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=9119
- https://bugzilla.redhat.com/show_bug.cgi?id=1956919
- https://chromium.googlesource.com/webm/libwebp/+/v1.0.1
- https://chromium.googlesource.com/webm/libwebp/+log/be738c6d396fa5a272c1b209be4379a7532debfe..29fb8562c60b5a919a75d904ff7366af423f8ab9?pretty=fuller&n=10000
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=9119
- https://bugzilla.redhat.com/show_bug.cgi?id=1956919
- https://chromium.googlesource.com/webm/libwebp/+/v1.0.1
- https://chromium.googlesource.com/webm/libwebp/+log/be738c6d396fa5a272c1b209be4379a7532debfe..29fb8562c60b5a919a75d904ff7366af423f8ab9?pretty=fuller&n=10000
Get alerted when CVE-2018-25011 or the next vulnerability affects your stack