What’s Vulnerable › Vulnerabilities
CVE-2018-25014
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 2.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-05-21 · updated 2026-06-17
- Weakness: CWE-908
Description
A use of uninitialized value was found in libwebp in versions before 1.0.1 in ReadSymbol().
Affected products
- Red Hat Enterprise Linux: 7.0, 8.0
- Chromium libwebp: before 1.0.1 — fixed in 1.0.1
How to fix
Upgrade to a fixed version: Chromium libwebp 1.0.1. Check the vendor advisory for mitigations.
References
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=9496
- https://bugzilla.redhat.com/show_bug.cgi?id=1956927
- https://chromium.googlesource.com/webm/libwebp/+log/78ad57a36ad69a9c22874b182d49d64125c380f2..907208f97ead639bd52
- https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=9496
- https://bugzilla.redhat.com/show_bug.cgi?id=1956927
- https://chromium.googlesource.com/webm/libwebp/+log/78ad57a36ad69a9c22874b182d49d64125c380f2..907208f97ead639bd52
Get alerted when CVE-2018-25014 or the next vulnerability affects your stack