What’s Vulnerable › Vulnerabilities
CVE-2018-25027
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2021-12-27 · updated 2026-06-17
- Weakness: CWE-416
Description
An issue was discovered in the libpulse-binding crate before 1.2.1 for Rust. get_format_info can cause a use-after-free.
Affected products
- Libpulse-Binding Project Libpulse-Binding: before 1.2.1 — fixed in 1.2.1
How to fix
Upgrade to a fixed version: Libpulse-Binding Project Libpulse-Binding 1.2.1. Check the vendor advisory for mitigations.
References
- https://raw.githubusercontent.com/rustsec/advisory-db/main/crates/libpulse-binding/RUSTSEC-2018-0021.md
- https://rustsec.org/advisories/RUSTSEC-2018-0021.html
- https://raw.githubusercontent.com/rustsec/advisory-db/main/crates/libpulse-binding/RUSTSEC-2018-0021.md
- https://rustsec.org/advisories/RUSTSEC-2018-0021.html
Get alerted when CVE-2018-25027 or the next vulnerability affects your stack