What’s Vulnerable › Vulnerabilities
CVE-2018-25047
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.1% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-09-15 · updated 2026-06-17
- Weakness: CWE-79
Description
In Smarty before 3.1.47 and 4.x before 4.2.1, libs/plugins/function.mailto.php allows XSS. A web page that uses smarty_function_mailto, and that could be parameterized using GET or POST input parameters, could allow injection of JavaScript code by a user.
Affected products
- Debian Linux: 10.0
- Smarty: before 3.1.47; from 4.0.0 before 4.2.1 — fixed in 3.1.47, 4.2.1
How to fix
Upgrade to a fixed version: Smarty 3.1.47, 4.2.1. Check the vendor advisory for mitigations.
References
- https://bugs.gentoo.org/870100
- https://github.com/smarty-php/smarty/issues/454
- https://github.com/smarty-php/smarty/releases/tag/v3.1.47
- https://github.com/smarty-php/smarty/releases/tag/v4.2.1
- https://lists.debian.org/debian-lts-announce/2023/01/msg00002.html
- https://security.gentoo.org/glsa/202209-09
- https://bugs.gentoo.org/870100
- https://github.com/smarty-php/smarty/issues/454
- https://github.com/smarty-php/smarty/releases/tag/v3.1.47
- https://github.com/smarty-php/smarty/releases/tag/v4.2.1
- https://lists.debian.org/debian-lts-announce/2023/01/msg00002.html
- https://lists.debian.org/debian-lts-announce/2024/11/msg00013.html
Get alerted when CVE-2018-25047 or the next vulnerability affects your stack