What’s Vulnerable › Vulnerabilities
CVE-2018-25048: Codesys Runtime Improper Limitation of a Pathname
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2023-03-23 · updated 2026-06-17
- Weakness: CWE-22
Description
The CODESYS runtime system in multiple versions allows an remote low privileged attacker to use a path traversal vulnerability to access and modify all system files as well as DoS the device.
Affected products
- CODESYS Control for BeagleBone: from 3.0.0.0 before 3.5.12.30 — fixed in 3.5.12.30
- CODESYS Control For Empc-A/Imx6: from 3.0.0.0 before 3.5.12.30 — fixed in 3.5.12.30
- CODESYS Control for IOT2000: from 3.0.0.0 before 3.5.12.30 — fixed in 3.5.12.30
- CODESYS Control for PFC100: from 3.0.0.0 before 3.5.12.30 — fixed in 3.5.12.30
- CODESYS Control for PFC200: from 3.0.0.0 before 3.5.12.30 — fixed in 3.5.12.30
- CODESYS Control for Raspberry Pi: from 3.0.0.0 before 3.5.12.30 — fixed in 3.5.12.30
- CODESYS Control Rte: from 3.0.0.0 before 3.5.12.30 — fixed in 3.5.12.30
- CODESYS Control V3 Runtime System Toolkit: from 3.0.0.0 before 3.5.12.30 — fixed in 3.5.12.30
- CODESYS Control Win: from 3.0.0.0 before 3.5.12.30 — fixed in 3.5.12.30
- CODESYS Embedded Target Visu Toolkit: from 3.0 before 3.5.12.30 — fixed in 3.5.12.30
- CODESYS Hmi: from 3.0 before 3.5.12.30 — fixed in 3.5.12.30
- CODESYS Remote Target Visu Toolkit: from 3.0 before 3.5.12.30 — fixed in 3.5.12.30
- CODESYS Runtime PLCWinNT: from 2.0.0.0 before 2.4.7.52 — fixed in 2.4.7.52
- CODESYS Runtime System Toolkit: from 2.0.0.0 before 2.4.7.52; 3.5.15.0 — fixed in 2.4.7.52
- CODESYS Simulation Runtime: from 3.0.0.0 before 3.5.12.30 — fixed in 3.5.12.30
How to fix
Upgrade to a fixed version: CODESYS Control for BeagleBone 3.5.12.30; CODESYS Control For Empc-A/Imx6 3.5.12.30; CODESYS Control for IOT2000 3.5.12.30; CODESYS Control for PFC100 3.5.12.30; CODESYS Control for PFC200 3.5.12.30; CODESYS Control for Raspberry Pi 3.5.12.30; CODESYS Control Rte 3.5.12.30; CODESYS Control V3 Runtime System Toolkit 3.5.12.30; CODESYS Control Win 3.5.12.30; CODESYS Embedded Target Visu Toolkit 3.5.12.30; CODESYS Hmi 3.5.12.30; CODESYS Remote Target Visu Toolkit 3.5.12.30. Check the vendor advisory for mitigations.
References
- https://customers.codesys.com/fileadmin/data/customers/security/2018/Advisory2018-04_CDS-59017.pdf
- https://customers.codesys.com/fileadmin/data/customers/security/2018/Advisory2018-04_CDS-59017.pdf
Get alerted when CVE-2018-25048 or the next vulnerability affects your stack