What’s Vulnerable › Vulnerabilities
CVE-2018-25050: Harvest Chosen abstract-chosen.coffee AbstractChosen cross site scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-28 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability, which was classified as problematic, has been found in Harvest Chosen up to 1.8.6. Affected by this issue is the function AbstractChosen of the file coffee/lib/abstract-chosen.coffee. The manipulation of the argument group_label leads to cross site scripting. The attack may be launched remotely. Upgrading to version 1.8.7 is able to address this issue. The name of the patch is 77fd031d541e77510268d1041ed37798fdd1017e. It is recommended to upgrade the affected component. The identifier of this vulnerability is VDB-216956.
Affected products
- Harvest Chosen: before 1.8.7 — fixed in 1.8.7
How to fix
Upgrade to a fixed version: Harvest Chosen 1.8.7. Check the vendor advisory for mitigations.
References
- https://github.com/harvesthq/chosen/commit/77fd031d541e77510268d1041ed37798fdd1017e
- https://github.com/harvesthq/chosen/pull/2997
- https://github.com/harvesthq/chosen/releases/tag/v1.8.7
- https://vuldb.com/?ctiid.216956
- https://vuldb.com/?id.216956
- https://github.com/harvesthq/chosen/commit/77fd031d541e77510268d1041ed37798fdd1017e
- https://github.com/harvesthq/chosen/pull/2997
- https://github.com/harvesthq/chosen/releases/tag/v1.8.7
- https://vuldb.com/?ctiid.216956
- https://vuldb.com/?id.216956
Get alerted when CVE-2018-25050 or the next vulnerability affects your stack