What’s Vulnerable › Vulnerabilities
CVE-2018-25052: Catalyst-Plugin-Session Session ID Session.pm _load_sessionid cross site scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-28 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability has been found in Catalyst-Plugin-Session up to 0.40 and classified as problematic. This vulnerability affects the function _load_sessionid of the file lib/Catalyst/Plugin/Session.pm of the component Session ID Handler. The manipulation of the argument sid leads to cross site scripting. The attack can be initiated remotely. Upgrading to version 0.41 is able to address this issue. The name of the patch is 88d1b599e1163761c9bd53bec53ba078f13e09d4. It is recommended to upgrade the affected component. VDB-216958 is the identifier assigned to this vulnerability.
Affected products
- Catalyst-Plugin-Session: before 0.41 — fixed in 0.41
How to fix
Upgrade to a fixed version: Catalyst-Plugin-Session 0.41. Check the vendor advisory for mitigations.
References
- https://github.com/perl-catalyst/Catalyst-Plugin-Session/commit/88d1b599e1163761c9bd53bec53ba078f13e09d4
- https://github.com/perl-catalyst/Catalyst-Plugin-Session/releases/tag/0.41
- https://vuldb.com/?ctiid.216958
- https://vuldb.com/?id.216958
- https://github.com/perl-catalyst/Catalyst-Plugin-Session/commit/88d1b599e1163761c9bd53bec53ba078f13e09d4
- https://github.com/perl-catalyst/Catalyst-Plugin-Session/releases/tag/0.41
- https://vuldb.com/?ctiid.216958
- https://vuldb.com/?id.216958
Get alerted when CVE-2018-25052 or the next vulnerability affects your stack