What’s Vulnerable › Vulnerabilities
CVE-2018-25053: moappi Json2html json2html.js cross site scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2022-12-28 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability was found in moappi Json2html up to 1.1.x and classified as problematic. This issue affects some unknown processing of the file json2html.js. The manipulation leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 1.2.0 is able to address this issue. The name of the patch is 2d3d24d971b19a8ed1fb823596300b9835d55801. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-216959.
Affected products
- moappi Json2html: before 1.2.0 — fixed in 1.2.0
How to fix
Upgrade to a fixed version: moappi Json2html 1.2.0. Check the vendor advisory for mitigations.
References
- https://github.com/moappi/json2html/commit/2d3d24d971b19a8ed1fb823596300b9835d55801
- https://github.com/moappi/json2html/releases/tag/1.2.0
- https://vuldb.com/?ctiid.216959
- https://vuldb.com/?id.216959
- https://github.com/moappi/json2html/commit/2d3d24d971b19a8ed1fb823596300b9835d55801
- https://github.com/moappi/json2html/releases/tag/1.2.0
- https://vuldb.com/?ctiid.216959
- https://vuldb.com/?id.216959
Get alerted when CVE-2018-25053 or the next vulnerability affects your stack