What’s Vulnerable › Vulnerabilities
CVE-2018-25055: FarCry Solr Pro Plugin Search solrProSearch.cfc cross site scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2022-12-28 · updated 2026-06-17
- Weakness: CWE-79
Description
A vulnerability was found in FarCry Solr Pro Plugin up to 1.5.x. It has been declared as problematic. Affected by this vulnerability is an unknown functionality of the file packages/forms/solrProSearch.cfc of the component Search Handler. The manipulation of the argument suggestion leads to cross site scripting. The attack can be launched remotely. Upgrading to version 1.6.0 is able to address this issue. The name of the patch is b8f3d61511c9b02b781ec442bfb803cbff8e08d5. It is recommended to upgrade the affected component. The identifier VDB-216961 was assigned to this vulnerability.
Affected products
- FarCry Solr Pro Plugin: through 1.5.0
References
- https://github.com/jeffcoughlin/farcrysolrpro/commit/b8f3d61511c9b02b781ec442bfb803cbff8e08d5
- https://github.com/jeffcoughlin/farcrysolrpro/issues/78
- https://github.com/jeffcoughlin/farcrysolrpro/releases/tag/1.6.0
- https://vuldb.com/?ctiid.216961
- https://vuldb.com/?id.216961
- https://github.com/jeffcoughlin/farcrysolrpro/commit/b8f3d61511c9b02b781ec442bfb803cbff8e08d5
- https://github.com/jeffcoughlin/farcrysolrpro/issues/78
- https://github.com/jeffcoughlin/farcrysolrpro/releases/tag/1.6.0
- https://vuldb.com/?ctiid.216961
- https://vuldb.com/?id.216961
Get alerted when CVE-2018-25055 or the next vulnerability affects your stack